Date   

Re: error while using scons pot

Fawaz Abdul rahman
 

Hi, the issue isn’t in scons, it is building fine. Just with scons pot. I have installed everything mentioned in the documentation, and as I mentioned, scons working fine.

Thanks.

 

Sent from Mail for Windows 10

 

From: Rémy Ruiz
Sent: Thursday, June 17, 2021 5:48 PM
To: nvda-addons@nvda-addons.groups.io; nvda-addons@groups.io
Subject: Re: [nvda-addons] error while using scons pot

 

Hi,

 

FYI:

 

## building the addon

You will need:

* python 3.6 or above.
* pip must be configured
* scons (pip install scons)
* markdown (pip install markdown)
* msgfmt utility. The easiest way of getting it is by installing git bash and choosing to include bash tools at command prompt

Once you have everything installed, issuing scons at the root of the project should build the addon and generate docs.

Cheers.

Rémy

Le 17/06/2021 à 16:08, Fawaz Abdul rahman a écrit :

Hello,

I’ve written an addon lately, now that it is complete and so, I wanted to translate it, but as far as I understood, I suppose to run ‘scons pot’ in the root directory, but I am getting the following dll errors, note that scons to create the package is working perfectly. No errors.

I didn’t want to download the dll files and place it in the pc before asking others. The errors are:

  • The code execution cannot proceed because libgettextsrc.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libintl3.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libexpat.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libiconv2.dll was not found. Reinstalling the program may fix this problem.

 

Any help will be appreciated.

Thanks a lot.

 

 

Sent from Mail for Windows 10

 

 


Re: error while using scons pot

 

Hi,

Actually, you’ll need Python 3.7 or above to align with NVDA Core.

Cheers,

Joseph

 

From: nvda-addons@nvda-addons.groups.io <nvda-addons@nvda-addons.groups.io> On Behalf Of Rémy Ruiz
Sent: Thursday, June 17, 2021 7:48 AM
To: nvda-addons@nvda-addons.groups.io; nvda-addons@groups.io
Subject: Re: [nvda-addons] error while using scons pot

 

Hi,

 

FYI:

 

## building the addon

You will need:

* python 3.6 or above.
* pip must be configured
* scons (pip install scons)
* markdown (pip install markdown)
* msgfmt utility. The easiest way of getting it is by installing git bash and choosing to include bash tools at command prompt

Once you have everything installed, issuing scons at the root of the project should build the addon and generate docs.

Cheers.

Rémy

Le 17/06/2021 à 16:08, Fawaz Abdul rahman a écrit :

Hello,

I’ve written an addon lately, now that it is complete and so, I wanted to translate it, but as far as I understood, I suppose to run ‘scons pot’ in the root directory, but I am getting the following dll errors, note that scons to create the package is working perfectly. No errors.

I didn’t want to download the dll files and place it in the pc before asking others. The errors are:

  • The code execution cannot proceed because libgettextsrc.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libintl3.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libexpat.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libiconv2.dll was not found. Reinstalling the program may fix this problem.

 

Any help will be appreciated.

Thanks a lot.

 

 

Sent from Mail for Windows 10

 


Re: error while using scons pot

Rémy Ruiz
 

Hi,


FYI:


## building the addon

You will need:

* python 3.6 or above.
* pip must be configured
* scons (pip install scons)
* markdown (pip install markdown)
* msgfmt utility. The easiest way of getting it is by installing git bash and choosing to include bash tools at command prompt

Once you have everything installed, issuing scons at the root of the project should build the addon and generate docs.

Cheers.

Rémy

Le 17/06/2021 à 16:08, Fawaz Abdul rahman a écrit :

Hello,

I’ve written an addon lately, now that it is complete and so, I wanted to translate it, but as far as I understood, I suppose to run ‘scons pot’ in the root directory, but I am getting the following dll errors, note that scons to create the package is working perfectly. No errors.

I didn’t want to download the dll files and place it in the pc before asking others. The errors are:

  • The code execution cannot proceed because libgettextsrc.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libintl3.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libexpat.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libiconv2.dll was not found. Reinstalling the program may fix this problem.

 

Any help will be appreciated.

Thanks a lot.

 

 

Sent from Mail for Windows 10

 


error while using scons pot

Fawaz Abdul rahman
 

Hello,

I’ve written an addon lately, now that it is complete and so, I wanted to translate it, but as far as I understood, I suppose to run ‘scons pot’ in the root directory, but I am getting the following dll errors, note that scons to create the package is working perfectly. No errors.

I didn’t want to download the dll files and place it in the pc before asking others. The errors are:

  • The code execution cannot proceed because libgettextsrc.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libintl3.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libexpat.dll was not found. Reinstalling the program may fix this problem.
  • The code execution cannot proceed because libiconv2.dll was not found. Reinstalling the program may fix this problem.

 

Any help will be appreciated.

Thanks a lot.

 

 

Sent from Mail for Windows 10

 


Re: UIASelectionItemPattern

Doug Lee
 

I'm not as good at this in NVDA as in other places, but I think there's a way to retrieve the property you want directly from the UIA object, without having first to grab a SelectionPattern object. I think it looks like this:

isSelected = obj._getUIACacheablePropertyValue(UIAHandler.UIA_SelectionItemIsSelectedPropertyId)

There may be a better way; I don't like calling stuff with underscores at the front because I assume they're meant to be private. I am drawing this approach from the Windows 10 App Essentials add-on though - file
appModules/solitaire.py.

On Thu, Jun 17, 2021 at 01:32:05AM -0700, falkogiepmans@babbage.com wrote:
Hi all,
For some application I have a tab control with tabs that are all UIA
objects. When I check it with Accessibility insights it shows that I
have a "SelectionItemPattern" with a a property IsSelected that is true
or false.
I want to obtain this value from the NVDA object that NVDA has assigned
to it ( NVDAObjects.UIA.UIA). This does have the
"UIASelectionItemPattern" property which returns a pointer. However, if
I try UIASelectionItemPattern.IsSelected it raises a KeyError. Can
anyone tell me what I do wrong?
Kind regards,
Falko


--
Doug Lee dgl@dlee.org http://www.dlee.org
Level Access doug.lee@LevelAccess.com http://www.LevelAccess.com
"Our chief want in life is somebody who will make us do what
we can. {Ralph Waldo Emerson}


Re: clipContentsDesigner compatible with NVDA 2021.1

Ján Kulik
 

Thanks for the clarification. I'm not on the github often, so I don't watch it that often. I thought that some authors of some add-ons forgot about it, so I have to point them out.


NVDA OCR question

Han Solo
 

Hello,


What kind of OCR does NVDA use?

Is it possible to implement Tesseract with options to enhance the image before recognition?

The results are very poor.

I have a script that makes recognition very efficient thanks to opencv.

Hence my question.


greetings


UIASelectionItemPattern

falkogiepmans@...
 

Hi all,

For some application I have a tab control with tabs that are all UIA objects. When I check it with Accessibility insights it shows that I have a "SelectionItemPattern" with a a property IsSelected that is true or false.

I want to obtain this value from the NVDA object that NVDA has assigned to it ( NVDAObjects.UIA.UIA). This does have the "UIASelectionItemPattern" property which returns a pointer. However, if I try UIASelectionItemPattern.IsSelected it raises a KeyError. Can anyone tell me what I do wrong?

Kind regards,
Falko
 
 


Re: clipContentsDesigner compatible with NVDA 2021.1

Noelia Ruiz
 

Hi Ján, thanks for pointing this out.

I create (with GitHub Actions) prereleases for testing. But links are
not permanent. Then, when I include some small changes, or even every
week, when GitHub Actions publish a prerelease where updated
translations are included, the direct link to download the add-on
changes since it's based in an identifier assigned by GitHub.
The best way to get these prereleases, at least for now, is to open
the link named Development build, and there you can search the direct
link. I may change this if needed.
I have planned, for this next weekend, send pull request to
addonFiles, including readFeeds, clipContentsDesigner and eMule, the
only add-ons maintained by me not sent to be included on the website
as compatible. To do this, previously I have to create stable releases
with a permanent link.
For now, please download the latest stable version of emoticons at

https://github.com/nvdaes/emoticons/releases/download/14.0/emoticons-14.0.nvda-addon

And the latest prerelease of clipContentsDEsigner:

https://github.com/nvdaes/clipContentsDesigner/releases/download/latest/clipContentsDesigner-db7e656c1f5f605d13aba08f34408b631322af16.nvda-addon

Please be aware: this last link, for clipContentsDesigner, will be
broken once updated translations are automatically send and a
prerelease is created.

Cheers

2021-06-17 9:32 GMT+02:00, Ján Kulik <jan.kulik.szsle@outlook.sk>:

I probably didn't have time to download it, the page is not found, I also
wanted to install an emoticon, but someone had to cleverly delete it






Re: clipContentsDesigner compatible with NVDA 2021.1

Ján Kulik
 

I probably didn't have time to download it, the page is not found, I also wanted to install an emoticon, but someone had to cleverly delete it


FW: [nvda-devel] NVDA 2021.1beta3 is now available for testing

 

 

 

From: nvda-devel@groups.io <nvda-devel@groups.io> On Behalf Of Reef Turner
Sent: Wednesday, June 16, 2021 9:25 PM
To: nvda-devel@groups.io
Subject: [nvda-devel] NVDA 2021.1beta3 is now available for testing

 

Hi all,

NVDA 2021.1beta3 is now available for testing. This is the third beta for the 2021.1 release, please install and test the release and report any issues.

Highlights and download links can be found in the release blog post at: https://www.nvaccess.org/post/nvda-2021-1beta3/

Thanks!


Re: Time zoner is not compatible wish NVDA 2021.1

 

sorry i selected UTC not UST
Windows 10 Insider build 21390.1010
NVDA version 2021.1beta2
 


Re: Time zoner is not compatible wish NVDA 2021.1

Rui Fontes
 

What Windows and NVDA versions?


Rui Fontes



Às 18:50 de 16/06/2021, Alexander Epaneshnikov escreveu:

hello. tried this addon. selected UST as a time zone.
when I trying to find out the time i get:
ERROR - stderr (20:48:47.779) - Thread-20 (22112):
Exception in thread Thread-20:
Traceback (most recent call last):
  File "threading.pyc", line 926, in _bootstrap_inner
  File "C:\Users\aarna\AppData\Roaming\nvda\addons\timezone\globalPlugins\timezone.py", line 112, in run
    self.sayInTimezone()
  File "C:\Users\aarna\AppData\Roaming\nvda\addons\timezone\globalPlugins\timezone.py", line 103, in sayInTimezone
    separator = selectedTz.index("/")
ValueError: substring not found
 


Re: Time zoner is not compatible wish NVDA 2021.1

 

hello. tried this addon. selected UST as a time zone.
when I trying to find out the time i get:
ERROR - stderr (20:48:47.779) - Thread-20 (22112):
Exception in thread Thread-20:
Traceback (most recent call last):
  File "threading.pyc", line 926, in _bootstrap_inner
  File "C:\Users\aarna\AppData\Roaming\nvda\addons\timezone\globalPlugins\timezone.py", line 112, in run
    self.sayInTimezone()
  File "C:\Users\aarna\AppData\Roaming\nvda\addons\timezone\globalPlugins\timezone.py", line 103, in sayInTimezone
    separator = selectedTz.index("/")
ValueError: substring not found
 


Notices on Add-on Updater and Windows 10 App Essentials development snapshots: testing new technologies

 

Hello all,

The following notice is applicable if you are using Add-on Updater and/or Windows 10 App Essentials add-on:

  • Add-on Updater: several community members are working on JSON add-ons metadata. Because it will take time to get the JSON metadata ready for public use, I’m delaying Add-on Updater’s switch to JSON metadata until August. Apart from that, Add-on Updater 21.07 is close at hand – the biggest change in that release will be use of toasts to announce add-on update availability on Windows 10 and later.
  • Windows 10 App Essentials: speaking of Windows 10, on June 17, 2021, a development version of Windows 10 App Essentials add-on will be released that will not install on anything other than latest NVDA beta and Windows Insider Preview build; in other words, you’ll need NVDA 2021.1 beta 2 or later (including alpha snapshots) and Insider Preview build 21390 or later in order to use this add-on build. This is designed to test fuller compatibility with upcoming Windows Sun Valley changes and to test how the add-on will work on NVDA 2021.1. This test will be going on for at least a week, and hopefully by early July, everyone using NVDA 2020.4 and Windows 10 Version 20H2 (build 19042) or later will get to use add-on development builds again. Also, the next stable version of Windows 10 App Essentials add-on will be released sometime in July – it will be either a major update (21.08) or scoped set of changes and backports (21.07); more details in July.

 

Cheers,

Joseph


Re: Miniaudible: request for accessibility.

Gabriele Battaglia
 

Hi Brian.
I don't think MacOS was the starting point. It's likely Windows. They simply didn't care about accessibility. They built this Small IDE which is inpre pre alpha version.

My guess is the inaccessibility has been brought by the fact they used QT.
Gabe.


Re: Miniaudible: request for accessibility.

Brian's Mail list account
 

Do they port it to other operating systems like Linux? I wondered if it might just be some kind of portable coding language with no accessibility. However if its written for Mac, I am not up in the latest portable solutions they may have if Mac OS was the starting point.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users

----- Original Message -----
From: "Gabriele Battaglia via groups.io" <iz4apu=libero.it@groups.io>
To: <nvda-addons@nvda-addons.groups.io>
Sent: Tuesday, June 15, 2021 7:43 AM
Subject: Re: [nvda-addons] Miniaudible: request for accessibility.


Reply to the Luke Davis's message, wrote on 14/06/2021 at 19:36:
Have you contacted the developers of this, to find out if they are willing to work toward accessibility?
Yep Luke. I sent a couple of message to their mailinglist and sent a private mail to one of the author.
No answers back yet.
Gabe.




Re: Add-on Updater 21.05.1 #addonrelease

Brian's Mail list account
 

Perhaps then, we should just leave things be until some fix for offering older versions is in situ. At the moment even without this I get asked to downdate on other add ons quite regularly, the only option at the moment is to stop add on updater actually looking for those.
Brian

bglists@blueyonder.co.uk
Sent via blueyonder.
Please address personal E-mail to:-
briang1@blueyonder.co.uk, putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users

----- Original Message -----
From: "Joseph Lee" <joseph.lee22590@gmail.com>
To: <nvda@nvda.groups.io>
Sent: Monday, May 24, 2021 6:20 PM
Subject: [nvda-addons] Add-on Updater 21.05.1 #AddonRelease


Hi all,

Add-on Updater 21.05.1 is now available with localization updates and making
the add-on compatible with just released NVDA 2021.1 beta 1. Until further
notice, you must install it manually from the following link (scroll down as
to why):

https://github.com/josephsl/addonUpdater/releases/download/21.05.1/addonUpda
ter-21.05.1.nvda-addon



IMPORTANT: for now you MUST apply this update manually. If you do apply it
manually, you must disable add-on update checks until further notice (NvDA
Menu/Preferences/Settings/Add-on Updater, turn off "Automatically check for
add-on updates") as Add-on Updater may offer earlier releases that are not
compatible with NvDA 2021.1. I'll provide an update once Add-on Updater
itself notices a new version of itself on its own, or if you have 21.05.1
manually installed, an earlier version of Add-on Updater is no longer
offered. The alternative is modifying add-on manifests manually, something I
advise many should not do because there are add-ons that will not work even
if you do modify add-on manifest to make them "compatible".



Cheers,

Joseph






Re: Time zoner is not compatible wish NVDA 2021.1

Ján Kulik
 

Thanks.


Re: Time zoner is not compatible wish NVDA 2021.1

Rui Fontes
 

Hi!


Get it here:

https://www.dropbox.com/s/qpp54fkq0sxrehz/timezone_1.04_Gen.nvda-addon?dl=1


Best regards,


Rui Fontes


Às 11:45 de 15/06/2021, Ján Kulik escreveu:

Hello.

Will the NVDA time zone add-on be available in NVDA 2021.1? I'm looking for a contact for the author but I can't find him E-mail. If the author is reading this email, please let us know
-
Ján Kulik

801 - 820 of 16478