Re: Debug Helper 1.0: new stable add-on released #addonrelease


Luke Davis
 

Thank you Ibrahim!

So just to confirm: you hear the beep when it should install, but no error is spoken, and there is no indication that the installation might have failed?

The most strange thing here, is that there is no install routine for this add-on, it is completely generic in that respect. So it shouldn't be trying to do anything unusual when installing, that all other add-ons don't also do.

Have you run the comtypes fixing tool recently?

Thanks again for the log.

Luke

On Sat, 24 Aug 2019, Ibrahim Hamadeh wrote:

hello
installing the addon on windows7 64bit,nvda 2019.2
got this error:
Requesting installation of add-on from C:\Users\ibrahim\nvda
add-ons\debugHelper-1.0.nvda-addon
DEBUG - windowUtils.getWindowScalingFactor (11:27:38.055):
GetDpiForWindow failed, using GetDeviceCaps instead
IO - speech.speak (11:27:38.875):
Speaking [LangChangeCommand ('en'), u'Add-on Installation dialog Are
you sure you want to install this add-on?\nOnly install add-ons from
trusted sources.\nAddon: Debug Helper 1.0']
DEBUGWARNING - synthDrivers.sapi4.SynthDriver.speak (11:27:38.878):
Unsupported speech command: LangChangeCommand ('en')
IO - speech.speak (11:27:38.887):
Speaking [LangChangeCommand ('en'), u'About add-on... button Alt+a']
DEBUGWARNING - synthDrivers.sapi4.SynthDriver.speak (11:27:38.888):
Unsupported speech command: LangChangeCommand ('en')
IO - inputCore.InputManager.executeGesture (11:27:52.809):
Input: kb(laptop):tab
IO - speech.speak (11:27:52.839):
Speaking [LangChangeCommand ('en'), u'Yes button Alt+y']
DEBUGWARNING - synthDrivers.sapi4.SynthDriver.speak (11:27:52.842):
Unsupported speech command: LangChangeCommand ('en')
IO - inputCore.InputManager.executeGesture (11:27:54.437):
Input: kb(laptop):space
IO - speech._speakSpellingGen (11:27:54.469):
Speaking character u'space'
DEBUGWARNING - synthDrivers.sapi4.SynthDriver.speak (11:27:54.469):
Unsupported speech command: LangChangeCommand ('en')
DEBUG - queueHandler.registerGeneratorObject (11:27:54.486):
Adding generator 13
IO - speech.speak (11:27:54.487):
Speaking [LangChangeCommand ('en'), u'pressed']
DEBUGWARNING - synthDrivers.sapi4.SynthDriver.speak (11:27:54.490):
Unsupported speech command: LangChangeCommand ('en')
DEBUG - queueHandler.pumpAll (11:27:54.545):
generator 13 finished
DEBUG - addonHandler.Addon.loadModule (11:27:54.737):
Importing module installTasks from plugin debugHelper
DEBUGWARNING - NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(11:27:54.769):
accRole failed: (-2147024809, 'The parameter is incorrect.', (None,
None, None, 0, None))
IO - speech.speak (11:27:54.788):
Speaking [LangChangeCommand ('en'), u'nvda add-ons']
DEBUGWARNING - synthDrivers.sapi4.SynthDriver.speak (11:27:54.789):
Unsupported speech command: LangChangeCommand ('en')
IO - speech.speak (11:27:54.822):
Speaking [LangChangeCommand ('en'), u'Items View list']
DEBUGWARNING - synthDrivers.sapi4.SynthDriver.speak (11:27:54.823):
Unsupported speech command: LangChangeCommand ('en')
IO - speech.speak (11:27:54.828):
Speaking [LangChangeCommand ('en'), u'debugHelper-1.0.nvda-addon 87 of
215']
DEBUGWARNING - synthDrivers.sapi4.SynthDriver.speak (11:27:54.828):
Unsupported speech command: LangChangeCommand ('en')
IO - tones.beep (11:27:54.882):
Beep at pitch 1760, for 40 ms, left volume 50, right volume 50
DEBUGWARNING - NVDAObjects.IAccessible.IAccessible._get_IAccessibleRole
(11:27:55.344):
accRole failed: (-2147024809, 'The parameter is incorrect.', (None,
None, None, 0, None))
ERROR - gui.addonGui.installAddon (11:27:55.345):
Error installing addon bundle from C:\Users\ibrahim\nvda
add-ons\debugHelper-1.0.nvda-addon
Traceback (most recent call last):
File "gui\addonGui.pyo", line 555, in installAddon
File "contextlib.pyo", line 24, in __exit__
File "gui\addonGui.pyo", line 538, in doneAndDestroy
RuntimeError: wrapped C/C++ object of type IndeterminateProgressDialog
has been deleted
--
but after opening the addon manager found it there pending restart
Debug Helper; Status: Install, Enabled after restart; Version: 1.0;
Author: Luke Davis <newanswertech@gmail.com>
closing the addon manager dialog and restart and it works as usual
without any problem.
regards.
ibrahim.

On 23-Aug-19 9:27 PM, Luke Davis wrote:
Would one or two others be willing to test this please? I am not
seeing any problems on Win 10 1903 64bit, NVDA beta or alpha, and some
earlier versions.

If you do test, please report your Windows and NVDA versions.

Again, the URL is:
https://github.com/XLTechie/debugHelper/releases/download/1.0/debugHelper-1.0.nvda-addon

Luke

On Fri, 23 Aug 2019, Ján Kulik wrote:

Hi, installation of the add-on has failed, it cannot be installed _.



Join nvda-addons@nvda-addons.groups.io to automatically receive all group messages.