Re: Possible Bug in Addon Updater


 

Hi,
I think this may have to do with urllib library in use. If doing a third
check for add-on updates succeeds, then yes, it is a temporary connection
problem that urllib didn't know about.
At the moment I have suspended add-on development except for major and
critical issues in order to concentrate on highest of highest of priority
work in NVDA (Python 3).
Cheers,
Joseph

-----Original Message-----
From: nvda-addons@nvda-addons.groups.io <nvda-addons@nvda-addons.groups.io>
On Behalf Of Luke Davis
Sent: Saturday, June 8, 2019 7:23 PM
To: nvda-addons@groups.io
Subject: [nvda-addons] Possible Bug in Addon Updater

I have only observed this once, which could mean it was a fluke, but it
seems a tad buggish.

1. An addon Updater window automatically appeared at some point, showing an
update for Win Ten App Essentials.
2. Right before noticing that, I turned off my laptop WiFI (hotkey),
thinking I was actually turning it on.
3. Then I hit "Update" to install the update.
4. Since there was now no internet access, I got an error dialog, saying
that it couldn't update.
5. Once I turned WiFI back on, I ran the NVDA->Tools->Check for addon
updates.
6. It reported "No addon update available". That is what I consider the bug:
it "forgot" that there was an update it had just told me about, because it
was unable to download it.
(N.B. should probably say "No addon updates available".) 7. I restarted
NVDA, ran step 5 again, and got the usual update dialog, which allowed me to
update W10AE.

Log attached.

Luke

Join nvda-addons@nvda-addons.groups.io to automatically receive all group messages.